Compiling problem

digitsensitive
Posted 5 months, 1 week ago in Bug Report, viewed 304 times

Hello there!

First: Thank you for creating a javascript fantasy console. It is great! Just wanted to compile the first game I created for the Fantasy Game Jam, but I am getting this error:

Compiled cart /usr/local/lib/node_modules/tako80/tako80.js:149 let imgData = new Buffer(img.padEnd(100)) ^

TypeError: img.padEnd is not a function at WriteStream.packCart (/usr/local/lib/node_modules/tako80/tako80.js:149:42) at emitNone (events.js:91:20) at WriteStream.emit (events.js:185:7) at finishMaybe (_stream_writable.js:512:14) at afterWrite (_stream_writable.js:386:3) at onwrite (_stream_writable.js:376:7) at WritableState.onwrite (_stream_writable.js:90:5) at fs.js:2195:5 at FSReqWrap.wrapper [as oncomplete] (fs.js:2162:5)

Is it the library or me?

Thanks, Eric

3 Replies
  • digitsensitive
    5 months, 1 week ago

    Oh fixed it already - did not have node.js up-to-date :-) Sorry about that.

  • digitsensitive
    5 months, 1 week ago

    Ok the compiling works but when uploading on itch.io I can not get the game to start:

    tako80.min.js:1 Uncaught TypeError: Cannot read property 'bind' of undefined at FileReader.fileReader.onload (tako80.min.js:1)

    Running the compiled version local I get:

    tako80.min.js:1 Uncaught (in promise) TypeError: Failed to fetch at Object.runcart (tako80.min.js:1) at Object.runcart (tako80.min.js:1) at index.html:49  Thanks for your answer. Eric

  • digitsensitive
    5 months, 1 week ago

    OK solved the problem, was a bit tricky :-)

    does not work -> function update() { works -> function update () {

Leave a Reply
Bug Report

Found a bug? Let me know about it here!